Author Topic: jQuery problem  (Read 1430 times)

Offline Bix

  • Full Member
  • *****
  • Posts: 30
  • Karma: +0/-0
jQuery problem
« on: January 17, 2017, 06:22:44 AM »
phpEnter Web Hosting
Hello,

First of all, a question: I've installed Beta Version of your beautiful script but I can't find any way to submit new posts from Admin panel, as in the previous versions: is that normal?

Anyway, my problem is another one: I've installed phpEnter Version 4.2.8 and I'm trying to customize it but I think there's a problem with jquery.min.js file.

The template of every original page on my site uses jquery.min.js version 1.9 (located in /scripts/jquery.min.js) to and your script uses version 1.4.4 (located in /news/scripts/jquery.min.js).

The problem is that if I use "both" versions or only the original one (1.9) the entire site and phpEnter work perfectly but when I click on an image in the phpEnter gallery (or news) the page changes, opening the single .jpg file, instead of open the pop-up with the captioned image.

If I use only "your" version (1.4.4), there's not that problem BUT some features of my original page doesn't work anymore (in particular, main menu's dropdown items)...

Is there a way to solve that?

Thanks in advance for any help.

Offline goli

  • Full Member
  • *****
  • Posts: 40
  • Karma: +2/-0
Re: jQuery problem
« Reply #1 on: January 18, 2017, 12:11:48 AM »
Try to change jquery version:

For example: <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>

All versions: 3.1.1, 3.1.0, 3.0.0, 2.2.4, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.4, 2.1.3, 2.1.1, 2.1.0, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.12.4, 1.12.3, 1.12.2, 1.12.1, 1.12.0, 1.11.3, 1.11.2, 1.11.1, 1.11.0, 1.10.2, 1.10.1, 1.10.0, 1.9.1, 1.9.0, 1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.2, 1.7.1, 1.7.0, 1.6.4, 1.6.3, 1.6.2, 1.6.1, 1.6.0, 1.5.2, 1.5.1, 1.5.0, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.2, 1.3.1, 1.3.0, 1.2.6, 1.2.3

https://developers.google.com/speed/libraries/


Offline Bix

  • Full Member
  • *****
  • Posts: 30
  • Karma: +0/-0
Re: jQuery problem
« Reply #2 on: January 19, 2017, 04:40:09 AM »
Try to change jquery version:

Done! That was a long looooong day: I've tried a (big) number of versions, starting from the newest, than from the oldiest and the good ones were... IN THE MIDDLE!!! ::)

But the important thing is that, finally, now it works!

Thank you  very much, goli!
  :)